Bugzilla Version 2.16.3
Bugzilla Bug 5802
  SuSE 10.3 two column printouts only using first column.
     Query page      Enter new bug
Bug#: 5802   Platform:   Reporter: raeburn@msu.edu (Stuart Raeburn)
Product:   OS:   Add CC:
Component:   Version:   CC:
Remove selected CCs
Status: RESOLVED   Priority:  
Resolution: FIXED   Severity:  
Assigned To: raeburn@msu.edu (Stuart Raeburn)   Target Milestone:  
URL:
Summary:

Attachment Type Modified Status Actions
Create a New Attachment (proposed patch, testcase, etc.) View All

Bug 5802 depends on: Show dependency tree
Show dependency graph
Bug 5802 blocks:
Votes:     Show votes for this bug    Vote for this bug

Additional Comments:


Leave as RESOLVED FIXED
Reopen bug
Mark bug as VERIFIED
Mark bug as CLOSED

View Bug Activity   |   Format For Printing

Description: Opened: 2008-09-20 20:49

Moved from bug 5757.

From Ray Batchelor  2008-09-20 02:42 -------

I am just becoming aware that we are haveing serious problems with printout
generation on our suse 10.3 access servers.  I'm hoping to find a quick fix....
but doubt that I can decipher how this discussion relates to my problem.  Any
advice would be appreciated.

Thanks.

From Ray Batchelor 2008-09-20 09:46 -------

On our suse10.3 access servers I see the following and I wonder if there should
not be more?

> rpm -qa | egrep tex
te_latex-3.0-58
texinfo-4.9-15
latex-ucs-20041017-31
perl-gettext-1.05-73
tetex-3.0-58
> 

From Ray Batchelor 2008-09-20 10:28 -------

Actually I may have overstated the problem, because I have inconsistent info 
resulting from specific resources causing print jobs to fail in different courses.

What I AM finding to be consistently true, however, is simply that on our
suse10.3 access servers, two-column printouts only use the first column on each
page.  That is not so disastrous, but still annoying.

------- Additional Comment #1 From Ray Batchelor 2008-09-21 11:55 -------
There might be a temporal aspect to this bug... on Friday Sept 19,2008 a couple
of students reported inability to print and one mentioned getting a popup
message saying:
"Cannot extract the embedded font 'T3Font_4'.  Some characters may not display
or print correctly."

I then tried to print their assignment and observed the same phenonmenon.  I
also observed it where it said 'T3Font_0'.

The printout resulting from these attempts was missing lots of text.
These things occurred on suse10.3 access servers. But not on the rhel5 library
server.

However, on Saturday Sept 20, 2008, I could generate printouts from the access
servers without missing any text, although two-column printouts ignore the
second column.  


------- Additional Comment #2 From Ray Batchelor 2008-09-22 01:12 -------
OK now I am unsure about anything.  I just got another report from a student
(who appears to have been using newton.science.sfu.ca, access server (suse10.3).
This student had just tried to generate a printout an found that lots of the
text was missing from it.  However, when I logged-on to newtons and printed this
students assignment, it print just fine and, what is more, both columns in the
2-column formatted page were used, as per normal.

This was course 
sfu_8A157312764b8489esfulc phys102
sequence "Assignment 3"

On the other hand, when I go to the course
sfu_2x196843c9cb0489fsfulc chem110
and choose to print sequence "Assignment 2"
it has no problem with any text but it still insists on leaving the second
column unused.  I can't think of a reasonable explanation for this behaviour.




------- Additional Comment #3 From Ron Fox 2008-09-22 06:58 -------
Maybe psnup is missing?

------- Additional Comment #4 From Ray Batchelor 2008-09-27 11:58 -------
Uh... nope.

------- Additional Comment #5 From Ray Batchelor 2008-09-27 12:06 -------
However, I have now installed suse10.3 and loncapa2.7.1 on my development server.
It has the following tex packages at present
# rpm -qa | grep tex
latex-ucs-20041017-31
gettext-0.16-47.2
perl-gettext-1.05-73
tetex-3.0-60
te_latex-3.0-60

On this machine, it appears that two-column printing might be working correctly
at least some of the time.  It seems to omit to use the second column however,
when there is a problem containing an html table in the list or resources to be
included in the printout.  (However, this is a very limited test, so it could
arise from something else.)

On my production access servers, however, double column printing seems to fail
even when the above condition is not satisfied.

Rather than try to figure out the exact set of conditions which cause this to
fail, I suppose I will now get rid of tetex on the dev server and see what
happens with TeXLive...

------- Additional Comment #6 From Ray Batchelor 2008-09-27 16:35 -------
OK here's what happens with TeXLive.  Printing of individual resources seems
fine.  I still observe disruption of 2-column printing in certain cases.

This has caused me to try to identify which resources and features are causing
the 2-column mode to fail.  I appear to have been mistaken that html tables were
a cause.  It was a coincidence.
What actually correlates with the failure to use the 2nd column is the inclusion
in the set of printed resources of an optionresponse problem in which one of the
selectable options is a string of >3 characters.
(Or, at least, that is one condition which definitely causes the 2-col failure.)

e.g. the following problem when included in a printed sequence causes the 2nd
column to be unused.

<problem><startouttext />stuff<br /><endouttext />
<optionresponse max="10" id="11" randomize="yes" TeXlayout="horizontal">
    <foilgroup options="('ab','cde','efgh')" texoptions="">
      <foil location="random" value="efgh" name="1">
         <startouttext /><endouttext />
      </foil>
    </foilgroup>
    <hintgroup showoncorrect="no">
    <startouttext /><endouttext />
    </hintgroup>
</optionresponse>
</problem>


------- Additional Comment #7 From Ray Batchelor 2008-09-27 16:53 -------
That was on suse10.3 with texlive on my dev (library) server.

On suse10.2 production access server, with tetex-3.0-58,
two-column printing fails under even broader conditions (but not completely
generally still).

For example a set which contains no optionresponse problems at all still does
not print in the 2nd column, on the latter server.

It seems to me quite likely that any resource which challenges the column width
might be a candidate for triggering this bug.

Note, again, that this bug does NOT occur on our RHEL5 library production server
running loncapa 2.7.0, and which uses the following packages:
tetex-fonts-3.0-33.2.el5_1.2
tetex-3.0-33.2.el5_1.2
tetex-dvips-3.0-33.2.el5_1.2
tetex-latex-3.0-33.2.el5_1.2
tetex-unicode-0-4.20041017.rhel5.lc
gettext-0.14.6-4.el5



------- Additional Comment #8 From Ray Batchelor 2008-09-29 11:49 -------
So, I'm not sure what to do about this at the moment.  I have left a message on
the login screens of our access servers advising students to generate printable
documents from the library server.  I'd like to be able to remove that message.

Eventually I think all of our production servers will be moved to RHEL and maybe
I should be lobbying to expedite that process here.  At least, that should
eliminate the two-col problem.

The random loss of fonts aspect to the bug, mentioned earlier might, of course,
be an entirely different issue, which I can't address very well until I can
figure out how to reproduce it at will.

------- Additional Comment #9 From Stuart Raeburn 2008-09-29 14:22 -------
Ray,

I built updated tetex, te_latex and latex-ucs RPMs for SuSE 10.3 (both 32 and 64
bit) and added them to the SuSe 10.3 testing repository at
install.loncapa.org/msu/testing/suse/10.3/

These RPMs are as follows:

32 bit:
te_latex-3.0-60.suse10.3.lc.i586.rpm
tetex-3.0-60.suse10.3.lc.i586.rpm  

64 bit
te_latex-3.0-60.suse10.3.lc.x86_64.rpm 
tetex-3.0-60.suse10.3.lc.x86_64.rpm

noarch
latex-ucs-20041017-31.suse10.3.lc.noarch.rpm

I have updated the two SuSE 10.3 instances (32 bit and 64 bit) which I have
running LON-CAPA in my testing cluster (fisher.lite.msu.edu and
dogger.lite.msu.edu) to use these RPMs and have generated printouts by printing
the contents of a directory in Construction Space.  In each case the directory
included the optionresponse problem provided in comment #6.  I have been unable
to produce a one column printout where there should be two columns - in all
cases both columns are used.

As regards the difference in packaging between RHEL5 and SuSE 10.3:

RHEL5 has:
tetex-fonts-3.0-33.2.el5_1.2
tetex-3.0-33.2.el5_1.2
tetex-dvips-3.0-33.2.el5_1.2
tetex-latex-3.0-33.2.el5_1.2
tetex-unicode-0-4.20041017.rhel5.lc

SuSE 10.3 has 
te_latex-3.0-60
latex-ucs-20041017-31
tetex-3.0-60

The tetex package for SuSE provides the following:
TeX
dvips
gentle
lametex
pictex
xtexsh
te_pscm
te_etex
te_pdf

Looking at the .spec files from the source rpms for tetex-unicode (RHEL5) and
latex-ucs (SuSE) it is apparent that they both provide unicode support for LaTeX
by packaging: http://www.unruh.de/DniQ/latex/unicode

The RHEL5 packaging includes the fonts in a separate package (tetex-fonts)
whereas SuSE includes them in the main tetex package.  If you compare
/usr/share/texmf/fonts for the two distributions you'll see that RHEL5 has
subdirectories for: ofm, ovf and ovp which are lacking in SuSE, and SuSE has an
afm subdirectory which is lacking in RHEL5.

The ofm, ovf and ovp subdirectories can be added to SuSE by installing: te_omega
 (which provides the Omega typesetting system, an extension of TeX, designed for
typesetting of all the world's languages).  Although this package is not
required for LON-CAPA I have included both 32 and 64 bit RPMs for this package
in the SuSE 10.3 repo in msu/testing.

My suggestion at this point would be to replace the texlive packages on crystal
with the latest versions of the tetex packages, and see if you still see the two
columns -> one column error. If the error is eliminated I'll move the new tetex
packages to the production repo install.loncapa.org/suse/10.3/ so you can update
nernst, lewis and newton.

If the column issue persists, even with the latest tetex packages, converting
the access servers to RHEL5 certainly would seem to be a good way to resolve the
issue, since you plan on making this change eventually anyway.

------- Additional Comment #10 From Ray Batchelor 2008-09-29 17:39 -------
Huh!  I guess I will remove TeXLive and re-include LON-CAPA-prerequisites and
tetex.  Then I will compare what I have on crystal with what you say you have,
and try yet again.   Grrrrr.


------- Additional Comment #11 From Ray Batchelor 2008-09-29 20:48 -------
Well when I remove texlive and restore LONCAPA-prerequisites I can no longer get
tetex-3.0-60
te_latex-3.0-60

apparently the specified repositories do not include a dependency  tetex-ams?

So I end up with 
tetex-3.0-58
te_latex-3.0-58

I don't know if I should be able to get back to 0-60 somehow?


------- Additional Comment #12 From Stuart Raeburn 2008-09-29 21:05 -------
Ray,

Is the SuSE 10.3 MSU testing repository one of the "Additional repositories"
included in the yast set-up for crystal?

See:
http://mail.lon-capa.org/pipermail/lon-capa-dev/2007-November/001852.html

Although that message only described the approach for SuSE 10.2 and older, the
same is true now for SuSE 10.3:  

Protocol:             HTTP
Server Name:          install.loncapa.org 

Directory on server:
suse 10.3             msu/testing/suse/10.3/

Authentication:       Anonymous 

As regards tetex_ams, there is a te_ams which is built when the tetex RPMs are
built from the src rpm.  Until now I haven't included it in the RPMs in the SuSE
repositories.  My SuSE 10.3 instances here at MSU didn't require it. 

I can add it the SuSE 10.3 repos in install.loncapa.org/msu/testing/suse/10.3,
but te_ams is not tetex_ams (even if they contain the same content).  I wonder
where that dependency is coming from.

The description for te_ams included in the .spec file for tetex is:

This package provides AmS-TeX some parts of AmS-LaTeX, which is
released by the American Mathematical Society. For using AmS-TeX,
AmS-LaTeX, or their styles, install this package
 

------- Additional Comment #13 From Ray Batchelor 2008-09-29 21:15 -------
Right... I did not have msu/testing/suse/10.3/

Interestingly, while I had 3.0-58 in there I tried to generate a pdf and
reproduced the kind of missing font problem which I have been observing
periodically on our access servers.

I am now running "you", which I hope will grab the 3.0-60 packages again.

------- Additional Comment #14 From Ray Batchelor 2008-10-02 13:32 -------
To bring this bug closer to date:
Using yast, I did restore tetex-3.0-60 and te_latex-3.0-60 to crystal.
Confirmed the existence of the bug.
Stuart confirmed it also using resources at:
/res/sfud/rayb/chem111/set2/
I believe you said that the dvi and latex output were no different from that on
a CentOS server which does not evince the bug and that you were having a look at
printout.pl.
Any new knowledge?

------- Additional Comment #15 From Ray Batchelor 2008-10-02 13:50 -------
Huh!  I just did a yast online update on crystal.
It complained of the install.loncapa.org repositories not being available.
Nontheless, after finishing, I found that I now have
tetex-3.0-60.suse10.3.lc
te_latex-3.0-60.suse10.3.lc


------- Additional Comment #16 From Ray Batchelor 2008-10-02 13:57 -------
and that definitely broke printouts for me.... will revert back, if I can.

------- Additional Comment #17 From Stuart Raeburn 2008-10-02 15:14 -------
interface/lonprintout.pm rev 1.536.2.3
xml/londefdef.pm rev 1.390.2.2

A side effect of the addition of '\usepackage[T1]{fontenc}' in 1.531 has been
the creation of Type 3 (bit map) fonts in the .ps file during printout generation.

In SuSE (with te_latex) this can prevent creation of the two column format by
pstops, and it also results in the creatio nof larger .ps files (bit maps are
generated at 8000 dpi res.).  On-screen rendering of the bit maps is poor/fails
for Acroread, Evince etc, even though printing may be OK. Acrobat Reader may
pop-up a warning about missing Type 3 fonts.

Addition of '\usepackage{lmodern}' allows the use of Type 1 fonts which avoids
these issues.

This fix appears effective regardless of the choice of TeX packaging on SuSE
10.3 - tetex (3.0-60) or texlive (picins.sty needs to be installed for texlive,
following the recipe in bug 5757 - separaet issue).

There is an additional benefit for CentOS 5 (and presumably RHEL5) as the
changes in lonprintout.pm and londefdef.pm will eliminate the frequent
generation of missing fonts when printing on those distros.  As a result,
printout generation should perform much better in 2.7.X on Fedora/RedHat/CentOS
when these changes are on production servers.

------- Additional Comment #18 From Ray Batchelor 2008-10-02 16:31 -------
interface/lonprintout.pm rev 1.536.2.3
xml/londefdef.pm rev 1.390.2.2

Can these be added to our existing suse10.3 lc2.7.0 access servers?


------- Additional Comment #19 From Ray Batchelor 2008-10-02 16:53 -------
Very good!  I put these files in /home/httpd/lib/perl/Apache/ on crystal (lc
2.7.1 suse10.3 library server) and the same resources now print OK in two columns.


------- Additional Comment #20 From Ray Batchelor 2008-10-02 19:34 -------
Have now placed these two files on nernst, lewis and newton (suse10.3 LC2.7.0
access servers), and all appears to be satisfactory. I have tested a variety of
printouts on all three.

     Query page      Enter new bug
This is Bugzilla: the Mozilla bug system. For more information about what Bugzilla is and what it can do, see bugzilla.org.
Actions: New | Query | bug # | Reports   New Account | Log In